2018-04-20 Frame Rate

Details about updates to Shores of Hazeron

2018-04-20 Frame Rate

Postby Haxus » Fri Apr 20, 2018 7:47 pm

Frame Rate
I put some considerable effort into improving render frame rate.

Frame rate on my computer improved but not as much as expected. A city of new style buildings is still slower than a city of old style buildings.

Of course, old style buildings are a lot simpler to render. They have no transparency, moving parts, blinking lights, custom textures, etc. They cannot possibly draw faster than old style buildings, which were optimized for speedy rendering on much slower computers.

The changes affect all things that get painted on the screen, not just new style buildings. Every bit of code that uses a shader got touched so there could be a bug. The changes to the software reached a nice plateau, hence the update. I will likely continue this topic another time.

There is a problem with spacecraft factories not making spacecraft. That will get my first priority on Monday morning.

No server changes are required so client updates can be posted as they finish building.

Ubuntu 16 and MacOS X for OpenGL 4.1 client updates have been posted.

Windows 64-bit client is building now. It will be posted as soon as it finishes.

Other clients will follow along after that.
User avatar
Haxus
Site Admin
 
Posts: 3030
Joined: Fri Jan 14, 2011 8:00 pm

Re: 2018-04-20 Frame Rate

Postby ximulator » Sat Apr 21, 2018 8:27 am

I have a new style ship that is appearing pitch-black inside and out. Only self-illuminated parts are showing. I've tried switching on-off the suit light, and cycling through dark/dim/bright lighting inside the ship. Some swivel chairs are rendering just fine however.

Edit: It only seems to be pitch-black when I am in orbit of a world, or landed on one. Flying around just a star or deep space shows the ship how it normally would.

Edit2: New-style buildings are also black in the same way, but only on my ringworld. Round worlds show them normally.
User avatar
ximulator
 
Posts: 19
Joined: Mon Feb 23, 2015 2:50 pm

Re: 2018-04-20 Frame Rate

Postby Haxus » Sat Apr 21, 2018 11:37 am

Thank you for that clue. It will help me get right to the problem.

Sorry for the bug.
User avatar
Haxus
Site Admin
 
Posts: 3030
Joined: Fri Jan 14, 2011 8:00 pm

Re: 2018-04-20 Frame Rate

Postby Vectorus » Sun Apr 22, 2018 2:45 pm

I am finding the same thing aboard my ships. Haven't narrowed down the conditions yet.

EDIT: Rooms that are NOT sunlit seem immune to the pitch blackness. You had probably guessed that.
User avatar
Vectorus
 
Posts: 184
Joined: Sat Mar 03, 2012 10:21 am


Return to Updates

Who is online

Users browsing this forum: No registered users and 2 guests

cron